Splunk Enterprise Security

Query to detect activity from inactive account

DawoodUlex
New Member

Hi Folks,

I want to create a correlation for inactive account activity including last login with timestamp and app used to login. Any suggestion would be helpful.

0 Karma
1 Solution

begleyj1
Path Finder

There are a couple routes to go from here. My recommendation would be to create a lookup of the user accounts, this should include AD username, email address, first and last name, and/or some unique identifier of the user. This lookup can be manual or automated (recommend automating through ldap/AD integration with Splunk). Once the lookup is configured, integrate your log sources that will identify authentication activity (Windows, O365, VPN,etc). Validate the log sources are parsing the fields correctly and compliant to the CIM standards. Once validated, add those indexes of log sources into the Authentication datamodel, then use your SPL to identify your requested criteria. Example search below:

|tstats `summariesonly` values(Authentication.app) as app values(Authentication.action)
from datamodel=Authentication.Authentication
where [inputlookup terminated_users.csv |fields user |rename user as Authentication.user]
by _time, Authentication.src, Authentication.user
|`drop_dm_object_name(Authentication)`

View solution in original post

0 Karma

begleyj1
Path Finder

There are a couple routes to go from here. My recommendation would be to create a lookup of the user accounts, this should include AD username, email address, first and last name, and/or some unique identifier of the user. This lookup can be manual or automated (recommend automating through ldap/AD integration with Splunk). Once the lookup is configured, integrate your log sources that will identify authentication activity (Windows, O365, VPN,etc). Validate the log sources are parsing the fields correctly and compliant to the CIM standards. Once validated, add those indexes of log sources into the Authentication datamodel, then use your SPL to identify your requested criteria. Example search below:

|tstats `summariesonly` values(Authentication.app) as app values(Authentication.action)
from datamodel=Authentication.Authentication
where [inputlookup terminated_users.csv |fields user |rename user as Authentication.user]
by _time, Authentication.src, Authentication.user
|`drop_dm_object_name(Authentication)`
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

[Puzzles] Solve, Learn, Repeat: Character substitutions with Regular Expressions

This challenge was first posted on Slack #puzzles channelFor BORE at .conf23, we had a puzzle question which ...

Splunk Community Badges!

  Hey everyone! Ready to earn some serious bragging rights in the community? Along with our existing badges ...

[Puzzles] Solve, Learn, Repeat: Matching cron expressions

This puzzle (first published here) is based on matching timestamps to cron expressions.All the timestamps ...