Splunk Enterprise Security

How to use tstats command with datamodel and like function

N92
Path Finder

How to use tstats command with like function.
Ex:

| tstats count(eval(Authentication.action, "failure%")) as failure,  count(eval(Authentication.action, "success%"))  as success by src

Why does it give an error?

0 Karma
1 Solution

harsmarvania57
Ultra Champion

Hi,

tstats does not support complex aggregation function. ref. doc https://docs.splunk.com/Documentation/Splunk/7.2.6/SearchReference/Tstats#Complex_aggregate_function...

So you can use below query

| tstats count from datamodel=Authentication by Authentication.src,Authentication.action
| stats sum(eval(if(like('Authentication.action', "failure%"),count,0))) as failure sum(eval(if(like('Authentication.action', "success%"),count,0))) as success by Authentication.src

View solution in original post

harsmarvania57
Ultra Champion

Hi,

tstats does not support complex aggregation function. ref. doc https://docs.splunk.com/Documentation/Splunk/7.2.6/SearchReference/Tstats#Complex_aggregate_function...

So you can use below query

| tstats count from datamodel=Authentication by Authentication.src,Authentication.action
| stats sum(eval(if(like('Authentication.action', "failure%"),count,0))) as failure sum(eval(if(like('Authentication.action', "success%"),count,0))) as success by Authentication.src
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...