Splunk Enterprise Security

How to implement multiple where conditions with like statement using tstats?

woodentree
Communicator

Hello,

We'd like to monitor configuration changes on our Linux host. For that we want to detect when in the datamodel Auditd the field nameis equal to /etc/audit/*, /etc/audisp/*, or /etc/libaudit.conf. Here is our basic search:

| tstats `security_content_summariesonly` count  from datamodel=Auditd where nodename=Auditd.Path by _time span=1s host Auditd.name
| `drop_dm_object_name("Auditd")`

The question is how can we implement in the same search 3 conditions below:

| where like(name,"%/etc/audit/%")
| where like(name,"%/etc/audisp/%")
| where name="/etc/libaudit.conf"

Logicaly it could be done via case statement, but we wasn't able to implement it. Do you have any ideas?

Thanks for the help.

0 Karma
1 Solution

sumanssah
Communicator

Try something like

 | tstats `security_content_summariesonly` count  from datamodel=Auditd where nodename=Auditd.Path by _time span=1s host Auditd.name     | `drop_dm_object_name("Auditd")`     

  | search name="*/etc/audit/*" OR name="*/etc/audisp/*" OR name="*/etc/libaudit.conf*"

View solution in original post

sumanssah
Communicator

Try something like

 | tstats `security_content_summariesonly` count  from datamodel=Auditd where nodename=Auditd.Path by _time span=1s host Auditd.name     | `drop_dm_object_name("Auditd")`     

  | search name="*/etc/audit/*" OR name="*/etc/audisp/*" OR name="*/etc/libaudit.conf*"

woodentree
Communicator

Exactly!
Thanks for the help.

0 Karma

cotyp
Path Finder

how about a multiple if statement? if(like(name, "etc....%"), "etc",if(like(name, "%audisp%"), "audisp"))

0 Karma

woodentree
Communicator

Hi @cotyp,
With tstats you can use only from, where and by clause arguments. Personally I don't know how can I implement multiple if statements with these argements 😞

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Your Feedback. Our Roadmap. Visit the PX Feedback Booth at .conf26

You use Splunk every day, come and help shape what's next.  Save Your Seat: Product-Focused Sessions at ...

Agentic SOC Triage: Investigating Splunk ES Notables with MCP Server and a Local LLM

The Problem: Too Many Alerts, Too Little Context Security operations teams running Splunk Enterprise Security ...

Painting a Clearer Picture: Creating Cross-Domain Visibility with AI Canvas

Watch Now Painting a Clearer Picture: Creating Cross-Domain Visibility with AI Canvas     Do you ever feel ...