Splunk Enterprise Security

Getting an error after degrading Splunk enterprise security.

Inayath_khan
Path Finder

Unable to initialize modular input "whois" defined in the app "SA-NetworkProtection": Introspecting scheme=whois: script running failed (exited with code 1)

Also while opening content management windows : Getting Could not load analytical stories

Kindly suggest!!

0 Karma

Morizard
New Member

Hi
I Have this problem too
my splunk version is 10.0.0
and my ES version 8.1.1
and i have
one search head 
one masternode
two indexer
one heavy forwarder
and i have this problem in my indexer



/opt/splunk/bin/splunk cmd python /opt/splunk/etc/peer-apps/SA-NetworkProtection/bin/whois.py --domain=google.com
Traceback (most recent call last):
File "/opt/splunk/etc/peer-apps/SA-NetworkProtection/bin/whois.py", line 14, in <module>
from SolnCommon.modinput import (BooleanField, Field, FieldValidationException,
ModuleNotFoundError: No module named 'SolnCommon'

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Vibe-coding, AI, and Splunkcraft: Highlights from the .conf26 Builder Bar

If you stopped by the Builder Bar at .conf26, thank you! This year, we brought ...

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...