Splunk Enterprise Security

ES - Why is Network Dashboard Not Populating?

code_assassin
Explorer

Hello Splunkies, 

Having some issues with getting ES dashboards to populate... 

Query for Network Traffic Dashboard titled, "Traffic Search" : 

| tstats `summariesonly` max(_time) as _time,values(All_Traffic.action) as action,values(All_Traffic.src_port) as src_port,count from datamodel=Network_Traffic.All_Traffic where * $action_dm$ $src_dm$ $dest_dm$ $transport_dm$ $dest_port_dm$ by All_Traffic.src,All_Traffic.dest,All_Traffic.transport,All_Traffic.dest_port
| `drop_dm_object_name("All_Traffic")`
| sort - count
| fields _time,action,src,src_port,dest,transport,dest_port,count



Error I get when launching: Error in 'TsidxStats': WHERE clause is not an exact query.

Thanks in advance for the help! 

 

Labels (2)
0 Karma

meetmshah
SplunkTrust
SplunkTrust

Hello @code_assassin If you are manually running this, it will not work as there are tokens mentioned in the search. A good approach would be to click on "Submit" button and validate if it's populating the results or not. If there are no results, you will need to validate if Data Model is having the values or not.

Perhaps, is this still an issue for you?

 

Please accept the solution and hit Karma, if this helps!

0 Karma

code_assassin
Explorer

I tried to specify an index based off a similar question however no dice. 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Observability Simplified: Combining User Experience, Application Performance & ...

Tech Talk Observability Simplified: Combining User Experience, Application Performance & Network ...

Event Series May & June: From Network Visibility to Service Intelligence

Unifying the Network: Moving from Alert Noise to Service Intelligence with Splunk ITSI In today’s hybrid ...