Splunk Enterprise Security

Can some one help me in explaining below Splunk ES Rule

vikram1583
Explorer

Rule Name : Abnormally High Number of Endpoint Changes By User

Description: Detects an abnormally high number of endpoint changes by user account, as they relate to restarts, audits, filesystem, user, and registry modifications.

| tstats count from datamodel=Endpoint.Filesystem where Filesystem.tag="change" by Filesystem.user | eval change_type="filesystem",user='Filesystem.user' | tstats append=T count from datamodel=Endpoint.Registry where Registry.tag="change" by Registry.user | eval change_type=if(isnull(change_type),"registry",change_type),user=if(isnull(user),'Registry.user',user) | tstats append=T count from datamodel=Change.All_Changes where nodename="All_Changes.Endpoint_Changes" by All_Changes.change_type,All_Changes.user | eval change_type=if(isnull(change_type),'All_Changes.change_type',change_type),user=if(isnull(user),'All_Changes.user',user) | stats count as change_count by change_type,user | xswhere change_count from change_count_by_user_by_change_type_1d in change_analysis by change_type is above medium

0 Karma

nickhills
Ultra Champion

The search looks in the change datamodel for changes that have happened on endpoints.
It looks for hosts which have had a higher number of changes per day that exceeds the medium average for that host and user.

Commonly if a host is compromised, an attacker will make multiple changes to try to exploit it for lateral movement or privilage escalation.

This search looks for hosts that may have been affected.

If my comment helps, please give it a thumbs up!
0 Karma

haider11
Observer

thank you for your explanation, is it recommended for end users or for systems?

I got many false positive alerts 

0 Karma

richgalloway
SplunkTrust
SplunkTrust

What part of that do you need explained?

---
If this reply helps you, Karma would be appreciated.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...

Network to App: Observability Unlocked [May & June Series]

In today’s digital landscape, your environment is no longer confined to the data center. It spans complex ...

SPL2 Deep Dives, AppDynamics Integrations, SAML Made Simple and Much More on Splunk ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...