Security

ignoreOlderThan Invalid for batch input

ips_mandar
Builder

Does ignoreOlderThanstanza in inputs.conf is Invalid for batch input?
I am getting error as-"Invalid key in stanza"

[batch:\\D:\...\*.zip]
move_policy = sinkhole
index=abc
ignoreOlderThan = 72h
Tags (1)
0 Karma
1 Solution

solarboyz1
Builder

A batch input does destructive reads of the files, so its not expecting older files to be in that location.
Which is why ignoreOlderThan isn`t listed as a valid option for a batch input:

https://docs.splunk.com/Documentation/Splunk/7.3.1/Admin/Inputsconf#BATCH_.28.22Upload_a_file.22_in_...

View solution in original post

0 Karma

solarboyz1
Builder

A batch input does destructive reads of the files, so its not expecting older files to be in that location.
Which is why ignoreOlderThan isn`t listed as a valid option for a batch input:

https://docs.splunk.com/Documentation/Splunk/7.3.1/Admin/Inputsconf#BATCH_.28.22Upload_a_file.22_in_...

0 Karma
Get Updates on the Splunk Community!

Splunk Training for All: Meet Aspiring Cybersecurity Analyst, Marc Alicea

Splunk Education believes in the value of training and certification in today’s rapidly-changing data-driven ...

Investigate Security and Threat Detection with VirusTotal and Splunk Integration

As security threats and their complexities surge, security analysts deal with increased challenges and ...

Observability Highlights | January 2023 Newsletter

 January 2023New Product Releases Splunk Network Explorer for Infrastructure MonitoringSplunk unveils Network ...