Security

forgot pass4SymmKey

Michael
Contributor

I inherited a cluster, setup properly, as far as I know. However, am getting the error:

"Bad Request — editTracker failed, reason='WARN: path=/masterlm/usage: Signature mismatch between license slave=//redacted// and this License Master. Please make sure that the pass4SymmKey setting in server.conf, "

when trying to point new systems to the license master.

I know the fix, but I don't know the plain-text pass4SymmKey phrase...

What are my recovery options?
Thanks!

0 Karma

robgora_deloitt
Path Finder

Best option is to create a new pass4SymmKey under the General Stanza for the Licensing server. You don't have to change the Cluster pass4symmKey. Once you change it for the License server, you can change it through out your cluster. And restart Splunk. This should take care of your issue.

jaracan
Communicator

Hi @robgora_deloitte, do you have the step by step guide on how to change the License Master's pass4SymmKey?

Do we need to enable maintenance mode for the Indexers? Or how do we change the pass4SymmKey on the Indexers?

Regards,
Kevin

0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

(view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...