Security

Why Deployment Client talks to Server with plain HTTP instead of HTTPS?

Engager

Even a client have enableSplunkdSSL = true, it don't try to setup SSL and send REST request via a plain HTTP, what is refused by a server ( SSL Error = error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request) and then logs that into the client WARN DeploymentClient - Unable to send handshake message to deployment server. Error status is: not_connected.

Why?
Thanks

0 Karma
1 Solution

Engager

It happened, because password for the key has been invalidated:

Can't read key file /opt/splunkforwarder/etc/auth/server.pem errno=151429224 error:0906A068:PEM routines:PEM_do_header:bad password read.
Couldn't initialize SSL Context for HTTPClient in ServerConfig
Can't read key file /opt/splunkforwarder/etc/auth/server.pem errno=151404653 error:0906406D:PEM routines:PEM_def_callback:problems getting password.
SSL context could not be created - error in cert or password is wrong
SSL will not be enabled

View solution in original post

0 Karma

Engager

It happened, because password for the key has been invalidated:

Can't read key file /opt/splunkforwarder/etc/auth/server.pem errno=151429224 error:0906A068:PEM routines:PEM_do_header:bad password read.
Couldn't initialize SSL Context for HTTPClient in ServerConfig
Can't read key file /opt/splunkforwarder/etc/auth/server.pem errno=151404653 error:0906406D:PEM routines:PEM_def_callback:problems getting password.
SSL context could not be created - error in cert or password is wrong
SSL will not be enabled

View solution in original post

0 Karma