Security

Splunkweb Certificate Error

Communicator

Hi,

I have added the following in web.conf

privKeyPath = etc/auth/splunkweb/privatekey.key
caCertPath = etc/auth/splunkweb/mycert.pem

I am not to login to the splunk page.When i looked into web_service.log i am getting below error

2014-04-15 12:29:40,921 ERROR [534cd8dc1020c9eb8] root:323 - Specified cert 'D:\Program Files\Splunk\etc\auth\splunkweb\privatekey.key' is encrypted with a passphrase. SplunkWeb does not support passphrase-encrypted keys at this time. To resolve the problem, decrypt the keys on disk, generate new
passphrase-less keys, or disable ssl for SplunkWeb.

Please help me in this.

Thanking you in advance.

Tags (2)
0 Karma

SplunkTrust
SplunkTrust

Hi ncbshiva,

assuming you have created the certs outside of Splunk you can use any guide found on the net on how to remove passphrase from ssl key.

cheers, MuS

SplunkTrust
SplunkTrust

Feel free to mark this as answered by ticking the tick - thx 🙂

0 Karma

Communicator

Can you tell me how to do this ..?

0 Karma

Champion

Remove the password from the cert file if mentioned. Splunkweb doesn't support certs with password