Security

Splunk web server external login

splunk_user_99
Engager

I'm using VirtualBox as a Virtual machine with CentOS 7 on it. I have used a NAT-adapter with port forwarding and a Host-only adapter. On the NAT-adapter I used port-forwarding for connecting to ssh and for http. Everything worked fine. I have installed splunk successfully.

When starting splunk i get the note that the splunk web interface is available on the Host-only created IP-address and the port 8000. I tried to to get access to the splunk enterprise interface on my local machine and it worked.

But now i wanted to get access to it from another pc, to make the splunk interface "global". How should i do that? I tried to set some configurations in the splunk-launch.conf and the web.conf configurations but it didnt worked out. Then I tried to set off my Host-only adapter and then i get the 127.0.0.1 address for hosting, but then i could not get access from the localhost to. The browser sends then a message that no data can be sent.

I would be very thankfull if someone could help me out.

Other information: I use a proxy and a firewall

0 Karma
1 Solution

ivanreis
Builder

I believe the issue is related with the VirtualBox network configuration and not on Splunk configuration itself. The splunk is visible from your machine but it is not from others at the same network, I recommend you verify the article below to validade your network configuration, for me it seems to be a Network Nat configuration for the external networks.
https://www.nakivo.com/blog/virtualbox-network-setting-guide/

View solution in original post

0 Karma

ivanreis
Builder

I believe the issue is related with the VirtualBox network configuration and not on Splunk configuration itself. The splunk is visible from your machine but it is not from others at the same network, I recommend you verify the article below to validade your network configuration, for me it seems to be a Network Nat configuration for the external networks.
https://www.nakivo.com/blog/virtualbox-network-setting-guide/

View solution in original post

0 Karma