Splunk TLS using 3rd party CA- Cannot connect to

Path Finder

Hello There,

I have been trying to secure my Splunk web using TLS certificates. I followed this link: Configure Splunk Web to use TLS certificates - Splunk Documentation.

Things to know:

I sent a signing request to a CA.

My server certificate file contains only the server certificate and the CA certificate (in this order)

My web.conf is the following:

enableSplunkWebSSL = true
privKeyPath = ..\mycerts\myServerPrivateKey.key
serverCert = ..\mycerts\splunk-web.pem
sslPassword =
startwebserver = true

As a result I can not connect to "This page isn't working right now" and when i restart splunk I get the message "web interface does not seem to be available", plus it takes like 50 min for Splunk to restart.

I suspect the fact that I am not including a CA or .csr file, but I am not sure since it's not indicated in the documentation, plus I tried adding the private key and the .csr file but still had the same error.

Can you help me to know what I am doing wrong please? any help would be appreciated 🙂

have a great day!

Labels (1)
0 Karma
Get Updates on the Splunk Community!

Build Scalable Security While Moving to Cloud - Guide From Clayton Homes

 Clayton Homes faced the increased challenge of strengthening their security posture as they went through ...

Mission Control | Explore the latest release of Splunk Mission Control (2.3)

We’re happy to announce the release of Mission Control 2.3 which includes several new and exciting features ...

Cloud Platform | Migrating your Splunk Cloud deployment to Python 3.7

Python 2.7, the last release of Python 2, reached End of Life back on January 1, 2020. As part of our larger ...