Security

Splunk SAML SSO with mellon on apache 2.4

Builder

I'm trying to configure SAML SSO to Splunk from an IdP. I've followed this guide to try get authentication working: http://blogs.splunk.com/2013/10/09/splunk-sso-using-saml-through-okta/

Environment: Ubuntu 14.04; Apache 2.4.7; mod-auth-mellon 0.7.0; Splunk Enterprise 6.3.1 configured with LDAP authentication and group mapping.

Configuration matches what is provided in the blog post. Apache logs show that it is unable to identify a user:

[authz_core:debug] mod_authz_core.c(802): AH01626: authorization result of Require valid-user : denied (no authenticated user yet)
[authz_core:debug] mod_authz_core.c(802): AH01626: authorization result of <RequireAny>: denied (no authenticated user yet)
[core:error] AH00027: No authentication done but request not allowed without authentication for /secret/endpoint/login. Authentication not configured?

So it seems that there is no authorization. Do I need to configure authentication within apache too? I've tried removing the MellonUser parameter and setting the user request header manually to admin to see what happens, but still fails with the above errors.

Any idea why auth is failing?

0 Karma
1 Solution

Builder

there was a number of issues - firstly, mismatched entity id in apache config compared to what the IdP was sending, and then other errors like signature algorithm support and redirecting.

The full solution is posted here: http://serverfault.com/questions/739756/splunk-saml-sso-from-an-idp-with-apache-mod-mellon-fails/739...

Prior to configuring SSO, Splunk was configured to authenticate against LDAP - the same ldap backend that the IdP uses.

View solution in original post

0 Karma

Builder

there was a number of issues - firstly, mismatched entity id in apache config compared to what the IdP was sending, and then other errors like signature algorithm support and redirecting.

The full solution is posted here: http://serverfault.com/questions/739756/splunk-saml-sso-from-an-idp-with-apache-mod-mellon-fails/739...

Prior to configuring SSO, Splunk was configured to authenticate against LDAP - the same ldap backend that the IdP uses.

View solution in original post

0 Karma