Security

Since splunk 6.4 some users do not see the "export" button anymore

yannK
Splunk Employee
Splunk Employee

I noticed that after upgrading to splunk 6.4, my user with a custom role cannot see the "export" button on the bottom of dashboards , or on the top of search results. While my admin see it.

Tags (4)
1 Solution

yannK
Splunk Employee
Splunk Employee

Figured that out
Those users were member of the custom role "interns".
and it does not inherit from other roles

And the role does not have the capability "export_results_is_visible"
When we compare in the authorize.conf defaults, this capability didn't exist prior to splunk 6.4.* .
and the setting is allowed by default to the role "user".

To allow the export, I updated my custom role to add the capability.

View solution in original post

yannK
Splunk Employee
Splunk Employee

Figured that out
Those users were member of the custom role "interns".
and it does not inherit from other roles

And the role does not have the capability "export_results_is_visible"
When we compare in the authorize.conf defaults, this capability didn't exist prior to splunk 6.4.* .
and the setting is allowed by default to the role "user".

To allow the export, I updated my custom role to add the capability.

surekhasplunk
Communicator

Hi @yannK,

I have a similar issue. I have "export_results_is_visible" capability getting imported well from another user role to my user role.
But still am not able to see export to pdf button in my dashboard page.

0 Karma
Get Updates on the Splunk Community!

Optimize Cloud Monitoring

  TECH TALKS Optimize Cloud Monitoring Tuesday, August 13, 2024  |  11:00AM–12:00PM PST   Register to ...

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...

Stay Connected: Your Guide to July and August Tech Talks, Office Hours, and Webinars!

Dive into our sizzling summer lineup for July and August Community Office Hours and Tech Talks. Scroll down to ...