Security

Search Unique Source IPs Associated with 10+ Unique Destination IPs

ltcsecurity
Observer

Hi all I’m new to Splunk so forgive my ignorance.  We’re currently using Splunk as a SIEM and I’m having trouble getting a search query put together.

What I’m looking for is:

Show me all unique sources that have initiated ICMP traffic.  I believe that I’m getting the correct results with the following search string.

index="indexabc" dest_port=0 | stats count by src_ip

The additional information I’m looking for is “by unique source IP (above) find those that have 10+ unique destination IPs (dest_ip).”

Tags (3)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

Try this.

index="indexabc" dest_port=0 
| stats count, dc(dest_ip) as UniqueDestinations by src_ip
| where UniqueDestinations >= 10
---
If this reply helps you, Karma would be appreciated.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...