Security

SSO SAML using ADFS

pl2345
Path Finder

I've tried for the past few days using every article and resource I can to get Splunk to work with SSO, but am ending up short.
We currently have an instance installed on a windows server that works fine with ADFS. I took over this position and they wanted a separate instance installed on a Linux box and to use ADFS as well. I'm using version 7.3.1 and the current errors in my splunkd.log file are errors in the XMLParser and SAML involving the func=xmlSecOpenSSLAppKeyLoadBIO and failed to load private pem key.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...