Security

Login connections made to splunk

akarivaratharaj
Communicator

I would like to fetch No. of logins on Splunk (how frequently my splunk is being accessed). It is basically, how many connections are made to splunk for indexing/searches.

I am unaware where this information will be available on Splunk. Could anyone please help me to know , how and where can I get this information.

0 Karma

mayurr98
Super Champion
0 Karma

akarivaratharaj
Communicator

Hi @mayurr98,

Thankyou for your quick response. I have referred the above link which you shared.

In that post they have mentioned the below query to find the number of logins made to Splunk.
"index=_audit info=succeeded action="login attempt" | stats count by user"

This query is giving only the count of logins which are made by splunk users. It is good enough. But in addition to this, I need the login attempts made by other servers/databases also. For example, I have setup a forwarder in Host X. All the required log details from the host X is forwarded to my splunk instance and index over there. So while indexing also, my splunk is been accessed by the host/forwarder. I would like to have that information also.

How about the logs available in "sourcetype=WinEventLog:Security"? I have referred some posts, where people were discussing about the EventCode 4625 or 4624 (login success/failure).

Any idea where can I get those logs too?

0 Karma

mayurr98
Super Champion

Hi well the link i have shared will give you info about only splunk as splunk by default stores internal logs like audit,introspection,etc. In order to index the remote host logs you would need to monitor those files.
In order to monitor windows event logs data refer this:
https://docs.splunk.com/Documentation/Splunk/7.2.3/Data/MonitorWindowseventlogdata

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Index This | What travels the world but is also stuck in place?

April 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...

Discover New Use Cases: Unlock Greater Value from Your Existing Splunk Data

Realizing the full potential of your Splunk investment requires more than just understanding current usage; it ...

Continue Your Journey: Join Session 2 of the Data Management and Federation Bootcamp ...

As data volumes continue to grow and environments become more distributed, managing and optimizing data ...