Security

Init script is not configured to run at boot.

albyva
Communicator

I have a FreeBSD box and I ran (./splunk enable boot-start) and got the following message:

Init script installed at /etc/rc.d/splunk.

Init script is not configured to run at boot.

What in this file (/etc/rc.d/splunk) needs to be configured to boot? And does anything need to be set in the rc.conf file to kick it off when it boots?

Tags (1)
0 Karma
1 Solution

snickered
Path Finder

I ran into this and thought I'd post my solution. Just change the rc script per this: http://lists.freebsd.org/pipermail/freebsd-current/2012-January/031246.html. Just change rcvar to "splunk_enable".

root@fbsd3:~ # diff -u /etc/rc.d/splunk.orig /etc/rc.d/splunk
--- /etc/rc.d/splunk.orig 2014-11-07 17:21:12.000000000 -0600
+++ /etc/rc.d/splunk 2014-11-08 09:24:36.000000000 -0600
@@ -12,7 +12,7 @@

name=splunk
extra_commands="status"
-rcvar=`set_rcvar`
+rcvar=splunk_enable
eval "${rcvar}=${${rcvar}:-'NO'}"

splunk_start()
root@fbsd3:~ #

View solution in original post

snickered
Path Finder

I ran into this and thought I'd post my solution. Just change the rc script per this: http://lists.freebsd.org/pipermail/freebsd-current/2012-January/031246.html. Just change rcvar to "splunk_enable".

root@fbsd3:~ # diff -u /etc/rc.d/splunk.orig /etc/rc.d/splunk
--- /etc/rc.d/splunk.orig 2014-11-07 17:21:12.000000000 -0600
+++ /etc/rc.d/splunk 2014-11-08 09:24:36.000000000 -0600
@@ -12,7 +12,7 @@

name=splunk
extra_commands="status"
-rcvar=`set_rcvar`
+rcvar=splunk_enable
eval "${rcvar}=${${rcvar}:-'NO'}"

splunk_start()
root@fbsd3:~ #

View solution in original post

MuS
SplunkTrust
SplunkTrust

Hi albyva,

You don't need to change anything in the start script nor in /etc/rc.conf.
What happens if you re-run the enable boot-start or run the /etc/rc.d/splunk script?

Cheers, MuS

0 Karma

albyva
Communicator

If I run the /etc/rc.d/splunk script I get a code error.

root@/opt/splunk/bin # sh /etc/rc.d/splunk

/etc/rc.d/splunk: set_rcvar: not found

eval: ${:...}: Bad substitution

0 Karma

albyva
Communicator

When I rerun the script, I get the same output of it not being configured to run at boot.

root@/opt/splunk/bin # ./splunk enable boot-start

Init script installed at /etc/rc.d/splunk.

Init script is not configured to run at boot.

0 Karma

strive
Influencer
0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!