Security

How to probably configure Splunk to set authnrequests to be signed by SHA-256 signature algorithm?

slee75
New Member

Hello, I'm trying to set the authnrequests to be signed by a sha256 cert, as that's a requirement of my ldp for SAML. However, when I look at the SAML trace, it looks like it's still getting sent as a SHA1:

   <SignedInfo>
        <CanonicalizationMethod 
            Algorithm="http://www.w3.org/2001/10/xml-exc-c14n#"/>
        <SignatureMethod 
            Algorithm="http://www.w3.org/2000/09/xmldsig#rsa-sha1"/>

My authentication.conf file shows it as rsa-sha256 though:

signAuthnRequest = true
signatureAlgorithm = RSA-SHA256
signedAssertion = true
sloBinding = HTTPPost

Anybody know what I'm missing?

0 Karma
1 Solution

suarezry
Builder

signatureAlgorithm = RSA-SHA256

Check out the authentication.conf spec:

signatureAlgorithm = RSA-SHA1 | RSA-SHA256
* This setting is applicable only for redirect binding.

I think the binding is HTTP Post by default. Check your SAML config:

alt text

Try changing it to HTTP Redirect (if your IdP supports it).

View solution in original post

0 Karma

suarezry
Builder

signatureAlgorithm = RSA-SHA256

Check out the authentication.conf spec:

signatureAlgorithm = RSA-SHA1 | RSA-SHA256
* This setting is applicable only for redirect binding.

I think the binding is HTTP Post by default. Check your SAML config:

alt text

Try changing it to HTTP Redirect (if your IdP supports it).

0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

 (view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...