Security

Can't log in on command line

Path Finder

I'm able to log in to the web interface and I'm a splunk admin. But when I try to log in on the command line I get a login failure. Is this something that's been seen before?

EDIT

The failure message says "Login Failed," I'm using bash on a Red Hat box. All local accounts, my coworkers can login to their splunk accounts on the CLI, but I can't.

EDIT 2

I tried again as the splunk user on the box, and the login worked fine. Is there a way to open that capability up to a user other than splunk?

Tags (2)
0 Karma

Splunk Employee
Splunk Employee

There is no restriction on who can log in via the CLI.

My guess is that you don't have a home directory defined, or the permissions on your home directory don't permit you to write the necessary information that will persist your session.

0 Karma

Contributor

The login ID on the GUI is different from the CLI, although the default credentials are the same (admin:changeme). If you have not changed the credential on the CLI, then use the default. You can change the password if you wish.

Also, on Win7, Splunk has issue with UAC. Run the CMD as Administrator and then perform your CLI commands.

Motivator

Also, are you trying to use the built-in 'admin' account or one you created? Are you using LDAP for login or local accounts for authentication?

0 Karma

Splunk Employee
Splunk Employee

Needs more ... details. What is the failure message? What shell? What OS?

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!