Security

CLI "login failed" error on DS

cnuguri_ncc
Path Finder

Hello all,

Configured custom ssl certificates on Deployment Server (both splunkd and splunk web), and deployment clients are connecting to DS fine on this setup.

But, command line login started failing after this while running any commands on DS, Need help in resolving this please ? (we have requireClientCert=false).

Thanks in Advance
Chetu

Labels (2)
0 Karma
1 Solution

codebuilder
SplunkTrust
SplunkTrust

Did you cycle Splunk after enabling web SSL? How are you running Splunk? As root, or another user?

----
An upvote would be appreciated and Accept Solution if it helps!

View solution in original post

0 Karma

codebuilder
SplunkTrust
SplunkTrust

Did you cycle Splunk after enabling web SSL? How are you running Splunk? As root, or another user?

----
An upvote would be appreciated and Accept Solution if it helps!
0 Karma

cnuguri_ncc
Path Finder

Thanks @codebuilder 


Not exactly sure how, but it started working. I can only think the restart (although a few times) must have fixed this.

 

0 Karma

cnuguri_ncc
Path Finder

Yes, restarted a few times.
Splunk is running as "Local System" on Windows.

0 Karma

codebuilder
SplunkTrust
SplunkTrust

What is the full command you are running? Also, have you looked at the the _audit index for any messages related to why the auth is not successful?

----
An upvote would be appreciated and Accept Solution if it helps!
0 Karma

codebuilder
SplunkTrust
SplunkTrust

It's asking for the Splunk admin account password that you would have created when installing Splunk. You can reset it via the web UI if you have access, or you can reset it with the user-seed.conf method.

https://community.splunk.com/t5/Security/How-to-Reset-the-Admin-password/m-p/10622

----
An upvote would be appreciated and Accept Solution if it helps!
0 Karma

cnuguri_ncc
Path Finder

@codebuilder Sorry for not being clear enough,  It fails when I enter the admin login details. The same username and password works with Splunk web though ( this is the admin account created at installation ).

And this started after I have setup SSL for splunkd port so wondering if that is affecting the CLI authentication ? Is there a way to setup cert authentication for CLI ?

Thanks
Chetu

0 Karma
*NEW* Splunk Love Promo!
Snag a $25 Visa Gift Card for Giving Your Review!

It's another Splunk Love Special! For a limited time, you can review one of our select Splunk products through Gartner Peer Insights and receive a $25 Visa gift card!

Review:





Or Learn More in Our Blog >>