Reporting

sendemail error search 5.0.2

Path Finder

Hello,

I'm sorry I am french and I dont have a good english but I really need your help. I am trying to send an email but I encounter that error :

Input is not proper UTF-8, indicate encoding ! Bytes: 0x92 0x61 0x20 0x70, line 233, column 76

I use release 5.0.2. I searched a long time before posting this but I don't understand what is going on. I tried to edit props.conf, sendemail.py but it still doesn't work. I read this error was fixed by 5.0.X releases so is it a bug from Splunk ? Splunk is running on Windows 2008 R2 64 bits.
My search command is : sourcetype="syslog" | sendemail to=my_account@domain.fr

Please help me.

Tags (1)
0 Karma
1 Solution

Path Finder

Ok I found the mistake. I'm in a local network and my Splunk server wasn't allowed to send emails. After that, I only had to check Email alert setting and keep empty Username and Password fields.
My command is :

| sendemail to=my_account@domain.fr sendresults=true

Regards

View solution in original post

Path Finder

Ok I found the mistake. I'm in a local network and my Splunk server wasn't allowed to send emails. After that, I only had to check Email alert setting and keep empty Username and Password fields.
My command is :

| sendemail to=my_account@domain.fr sendresults=true

Regards

View solution in original post

Path Finder

Thanks for your answer but, I did your command (soucetype="syslog" | stats count | head 1 | eval _raw="test event" | sendemail to=my_account@domain.fr) and I have the same issue, except a new line (now it's line 255...)
When I check python logs I have this :

2013-05-07 08:25:56,253 ERROR Sending email. subject="Splunk Results", results_link="None", recipients="['my_account@domain.fr']"

0 Karma

Path Finder

Ok, I have new issues. I did that command line :

| sendemail from=my_account@domain.fr to=my_account@domain.fr sendresults=true server=mail.domain.fr use_ssl=true username="my_account" user="acc" password="******"

When I write this commande, there is the same issue. If I don't use any security (ssl or tls) I have an authentication error. And if I use tls, it tells me that it's not suported by my mail server.

0 Karma

Path Finder

Hmm, I have an other log looking lie this :
2013-05-07 08:46:23,598 DEBUG simpleRequest > GET https://127.0.0.1:8089/servicesNS/nobody/search/admin/alert_actions/email [] sessionSource=direct
But, SSL is not activated on my Splunk and why the used port is 8089 ? Shouldn't use port 8000 ? Where can I configure it ?

0 Karma

Splunk Employee
Splunk Employee

Maybe your syslog data format is not friendly, try :
|stats count | head 1 | eval _raw="test event" | sendemail to=my_account@domain.fr

Also you can check if there are any errors in the python logs (the sendemail script is in python)
index=_internal source=*python.log*

Last thing, verify that you are using the latest script, not a local copy from an older one.

Path Finder

The Timezone is the default server timezone....

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!