Reporting

What could be causing this PDF error - version `GLIBC_2.4' not found on my 64 bit system?

rsimmons
Splunk Employee
Splunk Employee

2010-11-17 16:11:34,210 DEBUG FF stderr: LoadPlugin: failed to initialize shared library /apps/splunk/etc/apps/pdfserver/bin/firefox-x86_64/plugins/libflashplayer.so [/lib64/tls/libc.so.6: version `GLIBC_2.4' not found (required by /apps/splunk/etc/apps/pdfserver/bin/firefox-x86_64/plugins/libflashplayer.so)]

Tags (1)

rsimmons
Splunk Employee
Splunk Employee

The error message version `GLIBC_2.4' indicates a version issue.

You can use the command ls -l /lib64/tls/libc.so.6 to verify that you have the correct lib version.

On 64 bit systems glibc 2.4 is required for 64 bit systems, eg. Centos 5.0 or later)

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Vibe-coding, AI, and Splunkcraft: Highlights from the .conf26 Builder Bar

If you stopped by the Builder Bar at .conf26, thank you! This year, we brought ...

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...