Reporting

What could be causing this PDF error - version `GLIBC_2.4' not found on my 64 bit system?

rsimmons
Splunk Employee
Splunk Employee

2010-11-17 16:11:34,210 DEBUG FF stderr: LoadPlugin: failed to initialize shared library /apps/splunk/etc/apps/pdfserver/bin/firefox-x86_64/plugins/libflashplayer.so [/lib64/tls/libc.so.6: version `GLIBC_2.4' not found (required by /apps/splunk/etc/apps/pdfserver/bin/firefox-x86_64/plugins/libflashplayer.so)]

Tags (1)

rsimmons
Splunk Employee
Splunk Employee

The error message version `GLIBC_2.4' indicates a version issue.

You can use the command ls -l /lib64/tls/libc.so.6 to verify that you have the correct lib version.

On 64 bit systems glibc 2.4 is required for 64 bit systems, eg. Centos 5.0 or later)

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Data Management Digest – September 2026

    Welcome to the September 2026 edition of Data Management Digest! September brought a fresh wave of ...

Federated Search for CloudWatch Unified Data Store Is Generally Available

As organizations modernize their cloud environments, AWS workloads generate more security, operational, and ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...