Reporting

Truncated scheduled report in PDF

Communicator

Hi, We run scheduled report in Splunk 6.0.1 (build 189883). The PDF output is truncated. The report contains rows with multi-values column (over 500 values in each row).
The message looks like this in text, and in PDF, the message is messed up:

... Truncated. 10.5580693816%1 3s7h.o1w89n.0.0/16 Campus Network Campus Network On Campus

Thanks.

Tags (2)

Path Finder

Please see the Splunk Documentation for "Generate PDFs of your reports and dashboards".
http://docs.splunk.com/Documentation/Splunk/7.0.3/Report/GeneratePDFsofyourreportsanddashboards

Excerpt from documentation:


limits.conf

In the [pdf] stanza you can set the max_rows_per_table to set the maximum number of table rows that Splunk software will print out for simple results tables in a PDF. The default is 1000.

Note: This can lead to multi-page reports if your tables have lots and lots of rows. Reduce this number if you want to limit the number of pages that a table can generate for a PDF version of a dashboard.

Engager

I know its a little late but i'm adding a reply for those who may have stumble upon this question ( like I did).

I also faced the same issue. When I scheduled a pdf delivery, I noticed that of the 2,600 rows, most of it got truncated. I found out the issue is that Splunk has a default pdf report of 1000 rows, which splunk gives you an option to change when you export a report to pdf. However, Splunk does not give you that same option when you schedule a report and set the action to email a pdf. Thus email pdf is defaulted to 1000 rows and you wont be able to change it in the web UI.

To change it in the backend, go to outputs.conf. Increase the max_rows_per_table in the [pdf] stanza. That should fix the issue.

0 Karma

Explorer

Does anyone have an answer to this question ?
I am also facing similar problem in the scheduled PDF delivery.

0 Karma

Engager

I downvoted this post because wanted to upvote or bump the issue, not answer

0 Karma