Reporting

Splunk data logs spreadsheet

tacobell
New Member

I'm new to Splunk - and have been asked to create a spreadsheet that my global company can use to baseline our Proof of Concept (POC),
Specifically, how do you identify what you are forwarding e.g. if I wanted to identify specific machines what is the best approach .....to identify the log type or the machine type?????? Would the below be the best approach????

And then add for example "firewall with IPS" Under "Security" ???
Or "Cisco switch" under "network"?

Security | Custom Applications | Networks | databases | Servers | Smartphones | Virtual Machines | Web Services | Sensors

Tags (1)
0 Karma

alacercogitatus
SplunkTrust
SplunkTrust

Knowing this level of data requires you to enhance the data with Splunk asset lookups. The simplest approach is to say:

|tstats count by sourcetype source host

This will give you a count by each piece of metadata, most of which clue you in to what the data is. For example, access_combined is a default standard for Apache Web logs. WinEventLog:Security is the Windows Security log. If you need to go deeper than that, you will have to tell Splunk (via lookup) what each host in the environment is, what it does, etc....

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Splunk App Dev Quarterly Roundup: AI, Agents, and Innovation!

Another quarter, another wave of innovation. From complex integrations to pushing the limits ...

Federated Search for Dynamic Data Self Storage Is Now Generally Available on Splunk ...

 Splunk is excited to announce the General Availability of Federated Search for Dynamic Data Self Storage ...

Index This | What has many keys but can’t unlock a door?

July 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...