Reporting

Sendemail script execution failed and no python.log entry

cwilliamsonHFE
New Member

I am unable to get the sendemail command to send an email via either a saved search, or an on demand search. In the case of an on demand search (sample:)

index=dnsf "*error*"| stats count by host | sendemail [email protected] server=xxx-smtp.xxx maxtime=2m

The job times out with message "Script execution failed for external search command 'sendemail'". In the case of saved searches, I can see in the jobs log that the job completed, but there is no evidence that an email was fired or even attempted.

From reading other postings here, I have attempted to examine the python.log for evidence of email behavior but a wildcard search of the python.log returns no results... thank you for any help that you can afford

Tags (1)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...