Reporting

Reports are showing IP addresses instead of hostnames after upgrading to 4.1

Jaci
Splunk Employee
Splunk Employee

We have a report that provides a nightly email alert with inline results for every successful backup event.

Ever since we upgraded to 4.1 from 4.x, the reports are showing the IP address instead of the hostname.

Did something change in 4.1? And how can I fix this?

Tags (2)
1 Solution

gkanapathy
Splunk Employee
Splunk Employee

i'm assuming the data is syslog directly to a Splunk UDP port, and it's because by default we don't resolve IP addresses on a UDP port any more. connection_host in inputs.conf will reset it though.

View solution in original post

Lowell
Super Champion

Are you using an udp input?

Try adding connection_host = dns to your UDP input stanza.

See the following post: Lookups - using them to replace the host field

0 Karma

gkanapathy
Splunk Employee
Splunk Employee

i'm assuming the data is syslog directly to a Splunk UDP port, and it's because by default we don't resolve IP addresses on a UDP port any more. connection_host in inputs.conf will reset it though.

Jaci
Splunk Employee
Splunk Employee

Yes, thank you for the answer!

0 Karma
Get Updates on the Splunk Community!

2024 Splunk Career Impact Survey | Earn a $20 gift card for participating!

Hear ye, hear ye! The time has come again for Splunk's annual Career Impact Survey!  We need your help by ...

Optimize Cloud Monitoring

  TECH TALKS Optimize Cloud Monitoring Tuesday, August 13, 2024  |  11:00AM–12:00PM PST   Register to ...

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...