Reporting

How to enable an embedded report after I have disabled it to change the schedule?

cevyn
Explorer

If I embed a report when I create it, it's no problem.

But once it is a saved report or I have disabled embed to change the schedule, I cannot find a place to turn it back on. Advanced edit shows it as embed.enabled = 0.

But I cannot find the right flow of screens to actual embed it.

Tags (3)
1 Solution

burwell
SplunkTrust
SplunkTrust

The trick is that you need to be on the Reports page.

The settings -> searches, reports and alerts page does NOT allow you to embed.

1) So go to http:/yourserver/en-US/app/search/reports
2) find the report
3) Pull down Edit -> Edit Description, Edit Permissions... Embed
4) You will be asked to confirm if you want to Embed

I always edit my savedsearches and reports with the standard Settings -> searches, reports and Alerts. And was always lost finding Embed.

View solution in original post

burwell
SplunkTrust
SplunkTrust

The trick is that you need to be on the Reports page.

The settings -> searches, reports and alerts page does NOT allow you to embed.

1) So go to http:/yourserver/en-US/app/search/reports
2) find the report
3) Pull down Edit -> Edit Description, Edit Permissions... Embed
4) You will be asked to confirm if you want to Embed

I always edit my savedsearches and reports with the standard Settings -> searches, reports and Alerts. And was always lost finding Embed.

View solution in original post

quiltyja72
New Member

What if Embed isn't in the Edit Pull down?  Edit Description, Edit Permissions...is.

0 Karma

claudio_manig
Communicator

Saved a lot of headache, thanks a lot!
Shouldn't that be reported as a bug?

0 Karma

manirao
Explorer

How to disable the report that is embedded? Please help me.

Thanks in advance

0 Karma

cevyn
Explorer

burwell you are my hero! Take the rest of the week off!!! you cannot see it but I'm dancing around my desk !!!!

0 Karma

cmerriman
Super Champion

Have you tried to enable it through the original way in the report?

In the report, click edit>embed>enable report embedding

http://docs.splunk.com/Documentation/Splunk/6.5.0/Report/Embedscheduledreports

0 Karma

cmerriman
Super Champion

http://docs.splunk.com/Documentation/Splunk/6.3.5/Report/Embedscheduledreports

this is the doc for 6.3.5

the embed.enabled parameter is in savedsearches.conf. you should be able to change it there?

0 Karma

cevyn
Explorer

test embeddedstats ke 2016-10-14 14:11:00 UTC None mexxxxx search 0 Private | Permissions Enabled | Disable View recent | Run | Advanced edit | Clone | Move | Delete

advanced edit does not allow me to update it.

Is that where you mean. I'm at 6.3.5

0 Karma

cevyn
Explorer

That was my point. It works when you build the report. However after it is built and saved or if I disable embed in the UI , the entry is not there to add back. the URL you gave does not apply in that case.

You "cannot get there from here" as best I can tell. Unless the expectation is to always edit the config file rather than use the UI.

0 Karma

somesoni2
Revered Legend

If you mouce hover over the disabled embed button, what message does Splunk show you?

0 Karma

cevyn
Explorer

sorry you need to tell me what screen I should be in to hover over embed because on my system I don't even see embed . It only seems to appear at creation time of report.

Do you mean the screen where I have a list of reports?
Do you mean select the specific report from the above screen?
At Version 6.3.5

0 Karma

lukejadamec
Super Champion

embed.enabled = 0 means it is off. Set it to 1 to turn it on.

To do it with the UI see the workflow in this post:
http://blogs.splunk.com/2014/05/08/17682/

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!