Reporting

How can I control the host and root of HTML Links in Saved Search result emails?

oreoshake
Communicator

We had some issues with the way the splunk web server handled our internally signed SSL certs so we setup nginx to handle the ssl and just proxy requests to the local splunk server. The problem is that the links still show port 8000 which means we click the link, remove the port, and then we get to the desired page (nginx does a URL rewrite to add the s to http).

Is there a way to drop the port number from the links that are generated without changing the port the web server runs on? Is there another way to accomplish this goal?

Tags (2)
1 Solution

gkanapathy
Splunk Employee
Splunk Employee

In the Splunk Manager->Email Alert Settings, http://localhost:8000/en-US/manager/launcher/configs/conf-alert_actions/email/?action=edit set the "Link hostname" value to the desired target URL.

View solution in original post

0 Karma

gkanapathy
Splunk Employee
Splunk Employee

In the Splunk Manager->Email Alert Settings, http://localhost:8000/en-US/manager/launcher/configs/conf-alert_actions/email/?action=edit set the "Link hostname" value to the desired target URL.

View solution in original post

0 Karma

oreoshake
Communicator

Yep, that worked.

A useless side note: I thought it would have created the link host:80:8000 which apparently would have worked anyways (in FF, but not safari)

0 Karma

gkanapathy
Splunk Employee
Splunk Employee

or i guess 80 if you're doing a redirect anyway?

0 Karma

gkanapathy
Splunk Employee
Splunk Employee

what if you add an explicit port number, i.e., 443?

0 Karma

oreoshake
Communicator

I was able to change the hostname, but the port number is still in the link.

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!