Reporting

Fieldformat Command: Why does the number format display correctly in the Search App, but not in a scheduled email report?

emafront
Explorer

hi all,
when i try to format a number in splunk, it displays correctly in the search app, but when i schedule it to be forwarded by mail the formatting is lost
index=... | fieldformat Amount=tostring(Amount, "commas")

Splunk 6.1.3

Any help?
thanks

1 Solution

gkanapathy
Splunk Employee
Splunk Employee

the fieldformat command only affects how the data is displayed by web UI elements. It does not modify the data itself. When you send via email, you're sending the data. You will need to use eval instead of fieldformat if you want to change the sent data.

View solution in original post

gkanapathy
Splunk Employee
Splunk Employee

the fieldformat command only affects how the data is displayed by web UI elements. It does not modify the data itself. When you send via email, you're sending the data. You will need to use eval instead of fieldformat if you want to change the sent data.

View solution in original post

emafront
Explorer

great, thanks!!

0 Karma

jamesdaily
Explorer

This is confusing because when you Export the report results from the UI, the date format is preserved, but when you let Splunk email it on a schedule, the date format is lost.

It should at least be made consistent... As it stands, it's impossible to test report output without scheduling a report and reviewing the email.

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.