Reporting

Datamodel acceleration broken after adding fields - "cannot use search for missing acceleration data"

rmdfrb
Explorer

I modified the Splunk_SA_CIM Authentication data model to include some extra fields (account domains), and after re-enabling acceleration I get the follwing error:

The search for datamodel
'Authentication' failed to parse,
cannot use search for missing
acceleration data

I presume this means that the old TSIDX files are still sitting around but contain a different set of fields than are expected. I was under the impression that Splunk knew how to clean these up on its own (or at least clean things up after they age out of the summary range), but that is apparently not happening. Any ideas what has gone wrong? What would be the best way to clean up this mess in a distributed environment?

Thanks!

dmaislin_splunk
Splunk Employee
Splunk Employee

Remove any macro definitions from your data models and expand them. It will work fine after that.

0 Karma

m4him7
Path Finder

I am having the same issue. Did you find the solution?

0 Karma

dmaislin_splunk
Splunk Employee
Splunk Employee

Remove any macro definitions from your data models and expand them. It will work fine after that.

0 Karma
Get Updates on the Splunk Community!

Accelerate Service Onboarding, Decomposition, Troubleshooting - and more with ITSI’s ...

Accelerate Service Onboarding, Decomposition, Troubleshooting - and more! Faster Time to ValueManaging and ...

New Release | Splunk Enterprise 9.3

Admins and Analyst can benefit from:  Seamlessly route data to your local file system to save on storage ...

2024 Splunk Career Impact Survey | Earn a $20 gift card for participating!

Hear ye, hear ye! The time has come again for Splunk's annual Career Impact Survey!  We need your help by ...