Btool multiline values don't have the '\' between lines that conf files have. How do I make them appear?

Path Finder

Running btool to create a combined config file from default and local doesn't give me a working config file because the line continuation marks are missing:

A search in the existing savedsearches.conf looks like:

search = source="/path/to/logfile.log" checkoutId (checkoutWithVas OR checkoutWithNoVas)\
| regex "checkoutId=[\w\d-]{32}" \
| rex "Domain: (?[\w\d.]+) Path:"\

While the output of btool looks like:

search = source="/path/to/logfile.log" checkoutId (checkoutWithVas OR checkoutWithNoVas)
| regex "checkoutId=[\w\d-]{32}" 
| rex "Domain: (?[\w\d.]+) Path:"

Any way to make them magically appear?

Path Finder

I tried that, worked this problem out when splunk complained about the config I had dumped to file.

0 Karma

Esteemed Legend

Try dumping it to a file; it is possible that the terminal process is eating them when displaying to STDOUT.

0 Karma
Get Updates on the Splunk Community!

What’s New in Splunk Cloud Platform 9.1.2308?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.1.2308! Analysts can ...

Index This | Why do they call it hyper text?

November 2023 Edition Hayyy Splunk Education Enthusiasts and the Eternally Curious!  We’re back with another ...

State of Splunk Careers 2023: Career Resilience and the Continued Value of Splunk

For the past three years, Splunk has partnered with Enterprise Strategy Group to conduct a survey that gauges ...