Monitoring Splunk
Highlighted

new indexer not showing in Monitoring console

Builder

I have added a new indexer to the indexer cluster and I can see it in the Indexer clustering dashboard but I can't see in the monitoring console overview page.

Should anything be done in order to make the new indexer appear in the monitoring console.

0 Karma
Highlighted

Re: new indexer not showing in Monitoring console

Super Champion

Hi @nawazns5038
Set cluster label on master node if not already done . The label is useful for identifying the cluster in the monitoring console.
in $SPLUNK_HOME/etc/system/local/server.conf of master's node in [clustering] stanza add below line:

[clustering] 
cluster_label = cluster1

refer http://docs.splunk.com/Documentation/Splunk/7.0.1/DMC/Setclusterlabels
http://docs.splunk.com/Documentation/Splunk/7.0.1/Indexer/Configuremasterwithserverconf

0 Karma
Highlighted

Re: new indexer not showing in Monitoring console

Builder

Yes, It is set and the cluster was attached before and all the indexers could be seen, a new indexer was added to the cluster yesterday and unable to find only that one server in DMC ,

0 Karma
Highlighted

Re: new indexer not showing in Monitoring console

SplunkTrust
SplunkTrust

If the Indexer Clustering dashboard on the cluster master is correct, then try this: simply go to the Settings tab in the Monitoring Console and choose General Setup. (Not the overall Settings menu.)
Take a look at the servers listed. If everything looks reasonable, just click Save. You might also do something similar for Forwarder Setup within the MC.

This may clear older entries from the monitoring tables.

Highlighted

Re: new indexer not showing in Monitoring console

Builder

Yes I see the new indexer added to the instances list ..But it says the state is new

All others as configured

How can I change the settings so that It appears as configured just like others.

0 Karma
Highlighted

Re: new indexer not showing in Monitoring console

Builder

Go to Settings and then General Setup in monitoring Console and click on Apply Changes

It will change the state of the indexer from "new" to "configured"

View solution in original post