Monitoring Splunk

modular input and ERROR AdminManagerDispatch cannot call handler

clorne
Communicator

Hello,

I am trying to install a modular input.
On a standalone Splunk, there is no problem, the setup dashboard shows up perfectly.

But on an heavy forwarder I get the following error:
+200 ERROR AdminManagerDispatch - Cannot call handler 'TA_xxx' du to missing script 'my-script.py'.

The script is present in TA/bin/my_script.py
The TA/local/restmap.conf contains the stanza:

[admin_external:TA_string]
handlertype = python
handlerfile = my_script.py
handleractions = edit, list, remove, create

If anyone has a small idea ...

Cheers
Céline

Tags (1)
0 Karma

skalliger
Motivator

Sounds like a permission problem.

And usually the scripts don't require a run permission but after checking ownership of folders I would try to add +x to the script.

Skalli

0 Karma

clorne
Communicator

Hello Skalliger.
You were right. Our windows git has modified the properties of all the files and there was no x anymore.
This is solved.

Thanks a lot.
Best Regards
Céline

0 Karma

skalliger
Motivator

Thanks for the feedback. Accepting an answer keeps us motivated. 😛

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Rounding off the Splunk Dashboard Contest

What does a contest-winning Splunk dashboard look like? In this case, it isn't in a browser tab at all. It ...

A Four Part Event Series: AI + Observability: AI Agents, LLMs, Apps, & Infrastructure

AI + Observability: AI Agents, LLMs, Apps, & Infrastructure The rapid evolution of artificial intelligence ...