Monitoring Splunk

Report generate

sahildb
Engager

We need to generate report in splunk which can tell us my log sources and all server details are reporting to splunk.

 

 

is there any query we can use to fetch all the details.

Labels (1)
0 Karma
1 Solution

manjunathmeti
Champion

Hi @sahildb ,

Use tstats command to get the data.

| tstats count where index="*" by host

| tstats count where index="*" by source

 

If this reply helps you, an upvote/like would be appreciated.

View solution in original post

0 Karma

manjunathmeti
Champion

Hi @sahildb ,

Use tstats command to get the data.

| tstats count where index="*" by host

| tstats count where index="*" by source

 

If this reply helps you, an upvote/like would be appreciated.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...