Monitoring Splunk

Distributed Management Console not visible at all.

ccsfdave
Builder

Greetings,

I am currently in the Splunk 6.4 Administration class and we are working with the DMC quite a bit. I didn't even know the DMC existed in Splunk before because the DMC does not show in my environment at all. I am running v.6.3.3. Could there be a permission issue with my admin or do I need to enable or install something?

My SH Settings Screen

Thanks,

Dave

0 Karma
1 Solution

ccsfdave
Builder

Yeah so it was the most bone-head of solutions. The app (which thank you to @burwell for making me aware it is an app) was not visible. See my comment in this thread that shows that I do have the app installed. Fifth column shows it is not visible.

Sorry all. I'm embarrassed

View solution in original post

0 Karma

ccsfdave
Builder

Yeah so it was the most bone-head of solutions. The app (which thank you to @burwell for making me aware it is an app) was not visible. See my comment in this thread that shows that I do have the app installed. Fifth column shows it is not visible.

Sorry all. I'm embarrassed

View solution in original post

0 Karma

burwell
SplunkTrust
SplunkTrust

You could see if somehow DMC is not enabled.

  1. go to the apps page.. en-US/manager/search/apps/local
  2. Look for Distributed Management Consolealt text
0 Karma

ccsfdave
Builder

sigh yeah it's installed

alt text

0 Karma

burwell
SplunkTrust
SplunkTrust

Hi. What happens if you click on permissions?

Note that you have permissions on the other apps but you don't for this app.

That might give you a clue.

0 Karma

burwell
SplunkTrust
SplunkTrust

Hi. Could you be trying on a search head cluster member? It won't be visible there.

It has to be on a member that is not part of SHC.

ccsfdave
Builder

I only have one splunk enterprise search head so not a clustering issue.

0 Karma

devenjarvis
Path Finder

According to http://docs.splunk.com/Documentation/Splunk/6.3.3/DMC/DMCoverview you can only see the DMC if you are assigned the Splunk Enterprise admin role.

Are you able to first validate your role? Likely under Settings -> Users and Authentication -> Access Controls - > Users -> Your User

0 Karma

ccsfdave
Builder

Nope, not a user issue. If you look at the picture above, circled at the top, I am trying from the admin user.

0 Karma