Knowledge Management

How to list which data sources have datamodels

Zarack
Engager

I need to list which data sources have datamodels, I tried a few ways but none of them were effective, can you help me please.

Best regards

Valderlúcio.

Labels (1)
Tags (2)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

It would help to know what you've already tried.  Have you looked at it the other way, that is, what sources do each DM use?

| tstats count from datamodel=<DM name> by source

You  should be able to combine that with

| rest /services/data/models

and map to list the sources used by all datamodels.

---
If this reply helps you, Karma would be appreciated.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...

Step into “Hunt the Insider: An Splunk ES Premier Mystery” to catch a cybercriminal ...

After a whole week of being on call, you fell asleep on your keyboard, and you hit a sequence of buttons that ...