Knowledge Management

How to count the logs quickly that with eventtypes

xsstest
Communicator

I have an eventtype, but I want to count number of eventtype from nginx access log . then show on dashboard.

eventtype web_spider :

ua="spider" OR uri="spider" OR ua="bot" OR ua="monitor"

But nginx has a lot of logs , if use index=nginx eventtype="web_spider"|stats count,search speed will be very slow. Could I use tstats command to count ?

Tags (1)
0 Karma
1 Solution

mayurr98
Super Champion

yes you can use tstats command but you would need to build a datamodel for that.
Refer this for creating a data model
http://docs.splunk.com/Documentation/Splunk/7.0.1/PivotTutorial/Buildtutorialdatamodel

After creating a datamodel you can use tstats command

| tstats count FROM datamodel=<datamodel_name> where index=nginx eventtype="web_spider"

If you have a single query that you want it to run faster then you can try report acceleration as well.

Save a search index=nginx eventtype="web_spider"|stats count as report and then refer below link to do report acceleration
http://docs.splunk.com/Documentation/Splunk/7.0.2/Report/Acceleratereports

let me know if this helps!

View solution in original post

mayurr98
Super Champion

yes you can use tstats command but you would need to build a datamodel for that.
Refer this for creating a data model
http://docs.splunk.com/Documentation/Splunk/7.0.1/PivotTutorial/Buildtutorialdatamodel

After creating a datamodel you can use tstats command

| tstats count FROM datamodel=<datamodel_name> where index=nginx eventtype="web_spider"

If you have a single query that you want it to run faster then you can try report acceleration as well.

Save a search index=nginx eventtype="web_spider"|stats count as report and then refer below link to do report acceleration
http://docs.splunk.com/Documentation/Splunk/7.0.2/Report/Acceleratereports

let me know if this helps!

xsstest
Communicator

thank you very much ~I am a SPLUNK novice

0 Karma

logloganathan
Motivator

very good answer...

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...

Network to App: Observability Unlocked [May & June Series]

In today’s digital landscape, your environment is no longer confined to the data center. It spans complex ...

SPL2 Deep Dives, AppDynamics Integrations, SAML Made Simple and Much More on Splunk ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...