Knowledge Management

Find the target indexer node responsible for causing indexqueue blocked across multiple source indexer nodes

hrawat
Splunk Employee
Splunk Employee
index=_internal source=*splunkd.log*  host=<all indexer hosts> bucketreplicator full earliest=-15m | stats count dc(host) as num_indexer_blocked_by_peer by peer | where num_indexer_blocked_by_peer > 0 AND count > 0 | join type=left peer [ search index=_introspection  host=<all indexer hosts> hostwide earliest=-10m | stats values(data.instance_guid) as peer by host]
Tags (1)

hrawat
Splunk Employee
Splunk Employee

Now (10.x onwards) you can find the time target blocked.

index=_internal bucketreplicator host=< all idx hosts> source=*splunkd.log*  total_blocked_time_seconds | timechart max(total_blocked_time_seconds) by peer

index=_internal bucketreplicator host=< all idx hosts> source=*splunkd.log*  total_blocked_time_seconds | timechart max(total_blocked_time_seconds) by bid
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...