Knowledge Management

Data Model or Pivot dedup

romansul
New Member

I generated a Data Model and accelerated it. The data consists of Months (Jan, Feb, etc), Suppliers(A, B,C), Machines (hostnames) and the final output has to be a stacked barchart displaying count of Providers events on our Machines per Months.

The issue is that I only have to count a maximum of 1 event per Machine in a month. When I only searched directly, a simple "| dedup Month Provider Hostname" solved the problem but now, as the data model must be accelerated, I cannot use dedup. Also, I cannot find how to use dedup in the barchart search generated by Pivot UI.

Could somebody please point me a direction regarding a dedup alternative for DataModels or Pivot searches?
Thanks!

Tags (1)
0 Karma

lakshman239
Influencer

You could use | from datamodel:"your_dm_name" | stats count(Providers) count(hostname) by month and change as needed.

0 Karma

romansul
New Member

Thanks for the reply. If i use "datamodel" i've noticed that it will load the data very slow, as it will not use the accelerated version. Is there a way of specifying to use the accelerated data?

0 Karma

lakshman239
Influencer

you can use tstats , say something like | tstats count(Providers) count(hostname) from datamodel="your_dm_name" groupby dm_name.month

change as per your field names

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Design, Compete, Win: Submit Your Best Splunk Dashboards for a .conf26 Pass

Hello Splunkers,  We’re excited to kick off a Splunk Dashboard contest! We know that dashboards are a primary ...

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...

Network to App: Observability Unlocked [May & June Series]

In today’s digital landscape, your environment is no longer confined to the data center. It spans complex ...