Knowledge Management

Count multi value field in Data Model

guimilare
Communicator

Hello Splunkers.

I have a data model that contains a multi value field, called acao.
Looking at the data model, I have the following:

alt text

When I run the following query: | tstats count(DM.acao) from datamodel="My_DataModel", the result is 2.
However, I want it to count all occurrences, resulting in 8 (1 P and 7 X's).

How can I do this?

Thanks.
Best Regards,
GMA

0 Karma

kamlesh_vaghela
SplunkTrust
SplunkTrust

HI @guimilare,

Can you please try this?

| tstats count from datamodel="My_DataModel" by DM.acao | stats sum(count) as count

Thanks

0 Karma

Ayn
Legend

| tstats dc(DM.acao)?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

What’s New in Splunk AI: Volume 02

Welcome to the second edition of “What’s New in Splunk AI” where we look at the latest and greatest updates, ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Laser Bananas and Edge Hubs: Exploring Operational Technology (OT) Data Through a ...

  OT is a different environment to traditional IT and can have interesting challenges when interfacing the ...