Installation

Windows installation ends prematurely and then won't install

New Member

This is a straight forward install, nothing fancy, just trying to evaluate and i can't get it to install on 64 bit windows 7.
?

Labels (2)
0 Karma

Engager

This had been troubling me for a while, there was no right click 'Run as administrator' option for me.

I resolved this by running CMD as Administrator, then launching the installer from within CMD!

Worked a treat! Hope this helps.

New Member

Thank You. It helped me.

0 Karma

New Member

Ran CMD as Administrator and launched isntall from within CMD...still rolled back in Windows 7 64-bit.

splunk-6.4.3-b03109c2bad4-x64-release.msi

Tried 6.4.4, 6.4.2...etc etc etc..

0 Karma

Splunk Employee
Splunk Employee

Can't hurt to try the Microsoft tool System File Checker:

https://support.microsoft.com/en-us/kb/929833

0 Karma

New Member

I have the same problem. I get no description of what the problem acuatlly is. I guess that is that. 😞

0 Karma

New Member

what is this problem?

0 Karma

New Member

I have the same problem running the X64 , 8GB memory Windows 7 English . The installation interface does not open any install bar . Just after the beginning give the error message that was interrupted prematurely

0 Karma

Community Manager
Community Manager

Hi @dcalvin

Would you be able to provide more details? What exact version of Splunk were you trying to install? Did you get a message that said "Splunk Enterprise setup wizard ended prematurely..."?

0 Karma

New Member

The version that I installed is Splunk Light yet, and Every time I tried it, just not be working very well, so give me some details if U have some time. Thx.

0 Karma

New Member

Yes, I was trying to install the Enterprise Trial ver.

splunk-6.2.2-255606-x64-release.msi

I have it on the desktop, so installing locally.

Splunk>Enterprise windows comes up and it starts to run. Validating... copying...

Then rolls back the action...

Then ends prematurely because of an error and system has not been modified.
Click finish to end... blah blah...

I am domain admin and admin of this pc. I tried to redown the app, so pretty sure its a valid complete file.

Really want to evaluate this app. Thanks for any help.
Dawn

0 Karma

New Member

Any ideas?

0 Karma

Splunk Employee
Splunk Employee

Just to confirm two more points: is this Windows running in English? Do you have an administrators group with a localized name? There have been Answers postings that point in that direction, although I suspect it doesn't apply in your case.

Can you supply the MSIxxxxxx.log file? This is normally found in %temp%. There should also be a splunk.log file (sometimes Windows puts it in the directory right above %temp%).

0 Karma

New Member

Thanks Chris. I just spun up a vm with with server 2012 and its running fine on there.
Case closed.
Thanks agian!

0 Karma

Motivator

hi dcalvin,
try to install other version and check if you have the same problem because i have install
splunk-6.2.0-255606-x86-release.msi and have the same problem that you, but when i have change the version and install the version splunk-6.2.2-255606-x86-release.msi. i don't have the problem again.

try change the version of splunk.
please forgive my english

0 Karma