Installation

Upgraded from Splunk 7.0.3 to 7.2.1 and the Splunk Web Server is unavailable.

christopherr_sp
Splunk Employee
Splunk Employee

Upgraded from Splunk 7.0.3 and 7.2.1 the Splunk Web Server is unavailable.

When Splunk is started from the command line, the following output appears on the screen:

Waiting for web server at http://127.0.0.1:8000 to be available...........................
..........................................................................................

WARNING:  web interface does not seem to be available!
Labels (1)
0 Karma
1 Solution

christopherr_sp
Splunk Employee
Splunk Employee

The workaround is to disable health reporting in health.conf (until the Bug is fixed in Splunk 7.2.x).

The issue is a known and is caused by the Bugs below.

SPL-162549
splunkweb fails to start and SHC member shows as down
Affects: 7.1.4
Fixed in: 7.1.6

SPL-160230
Splunkd web fails to start due to deadlock among Health Reporter threads
Affects: 7.1.2
Fixed in: 7.1.6

Steps

  1. Make the changes to the file below:

/etc/system/local/health.conf

[clustering]
disabled = 1

[feature:batchreader]
disabled = 1

[feature:tailreader]
disabled = 1

[feature:s2s_autolb]
disabled = 1

[feature:indexers]
disabled = 1

[feature:data_durability]
disabled = 1

[feature:cluster_bundles]
disabled = 1

[feature:indexing_ready]
disabled = 1

[feature:data_searchable]
disabled = 1

[feature:searchheadconnectivity]
disabled = 1

[feature:replication_failures]
disabled = 1

[feature:master_connectivity]
disabled = 1

[feature:slave_state]
disabled = 1

[feature:slave_version]
disabled = 1

2.Restart Splunk.

View solution in original post

0 Karma

christopherr_sp
Splunk Employee
Splunk Employee

The workaround is to disable health reporting in health.conf (until the Bug is fixed in Splunk 7.2.x).

The issue is a known and is caused by the Bugs below.

SPL-162549
splunkweb fails to start and SHC member shows as down
Affects: 7.1.4
Fixed in: 7.1.6

SPL-160230
Splunkd web fails to start due to deadlock among Health Reporter threads
Affects: 7.1.2
Fixed in: 7.1.6

Steps

  1. Make the changes to the file below:

/etc/system/local/health.conf

[clustering]
disabled = 1

[feature:batchreader]
disabled = 1

[feature:tailreader]
disabled = 1

[feature:s2s_autolb]
disabled = 1

[feature:indexers]
disabled = 1

[feature:data_durability]
disabled = 1

[feature:cluster_bundles]
disabled = 1

[feature:indexing_ready]
disabled = 1

[feature:data_searchable]
disabled = 1

[feature:searchheadconnectivity]
disabled = 1

[feature:replication_failures]
disabled = 1

[feature:master_connectivity]
disabled = 1

[feature:slave_state]
disabled = 1

[feature:slave_version]
disabled = 1

2.Restart Splunk.

0 Karma
Get Updates on the Splunk Community!

Stay Connected: Your Guide to July and August Tech Talks, Office Hours, and Webinars!

Dive into our sizzling summer lineup for July and August Community Office Hours and Tech Talks. Scroll down to ...

Edge Processor Scaling, Energy & Manufacturing Use Cases, and More New Articles on ...

Splunk Lantern is a Splunk customer success center that provides advice from Splunk experts on valuable data ...

Get More Out of Your Security Practice With a SIEM

Get More Out of Your Security Practice With a SIEMWednesday, July 31, 2024  |  11AM PT / 2PM ETREGISTER ...