Installation

How to resolve KV port change error - upgrade from 6.1 to 6.2 on Ubuntu x64?

Explorer

Hello!
I upgraded splunk 6.1 to 6.2, tried to start new version but received a error:

Checking kvstore port [3433593128]: invalid; must be between 1 and 65535
Would you like to change ports? [y/n]: y
Enter a new kvstore port: 54321
Setting kvstore to port: 54321
Did not find "disabled" setting of "kvstore" stanza in server bundle.
Error changing port, exiting

Could you advice me anything, please?

Labels (1)
0 Karma
1 Solution

Explorer

It hadn`t worked because I copied old etc-folder.
I updated splunk again and now it works.
Thank you for your help!

View solution in original post

Explorer

It hadn`t worked because I copied old etc-folder.
I updated splunk again and now it works.
Thank you for your help!

View solution in original post

Splunk Employee
Splunk Employee

How did you perform an upgrade to Splunk 6.2?
Could you do

head -1 $SPLUNK_HOME/etc/system/default/server.conf

This should tell that the version is 6.2.
Also please verify that server.conf has a default kvstore settings in it

$ tail -11 $SPLUNK_HOME/etc/system/default/server.conf
[kvstore]

disabled = false

port = 8191
replicaset = splunkrs
distributedLookupTimeout = 30
shutdownTimeout = 100
initAttempts = 300

dbPath = $SPLUNK_DB/kvstore