Installation

How do you install MAXMIND

Communicator

Hello,

I can't see any documentation on how to install MAXMIND anywhere. Please can somebody tell me how to install it?

Many Thanks

Tags (2)
0 Karma

New Member

sudo apt-get install build-essentials
sudo yum install build-essentials

or just

sudo apt-get install gcc
sudo yum install gcc

0 Karma

Communicator

Hello,

I am trying configure / install Maxmind GeoOIP for use with quite a few apps in Splunk. However when trying to install I am getting the following error, I would really appreciate any help.

root@server:/opt/splunk/etc/apps/Maxmind/Python-1.2.7# python setup.py build
running build
running buildext
building 'GeoIP' extension
creating build
creating build/temp.linux-x86
64-2.7
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -I/usr/local/include -I/usr/include/python2.7 -c pyGeoIP.c -o build/temp.linux-x8664-2.7/py_GeoIP.o
unable to execute gcc: No such file or directory
error: command 'gcc' failed with exit status 1

Many Thanks

0 Karma

Legend

Well, it seems you need to install gcc?

0 Karma