Installation

How do you get splunk to work with RHEL AS2.1?

Alan_Bradley
Path Finder

WHen I try to install it gives me a message that GLIBC-2.3 is required but there is no support to get this package for RHEL AS 2.1?

Tags (1)
0 Karma
1 Solution

matt
Splunk Employee
Splunk Employee

glibc version 2.3 is a mandatory requirement for running Splunk. Please consult http://www.splunk.com/base/Documentation/4.1/Installation/Systemrequirements for a list of all system requirements required to run Splunk.

If your current linux distro does not support this library then you will need to either upgrade your distro or find another machine running a newer distro. You may be able to run Splunk in a chrooted environment but I suspect that if the base OS does not support glibc 2.3 then the chrooted environment will not either (this is something that has not been tested). Instructions on installing Splunk in a chrooted environment can be found here: http://www.splunk.com/support/1228

View solution in original post

0 Karma

matt
Splunk Employee
Splunk Employee

glibc version 2.3 is a mandatory requirement for running Splunk. Please consult http://www.splunk.com/base/Documentation/4.1/Installation/Systemrequirements for a list of all system requirements required to run Splunk.

If your current linux distro does not support this library then you will need to either upgrade your distro or find another machine running a newer distro. You may be able to run Splunk in a chrooted environment but I suspect that if the base OS does not support glibc 2.3 then the chrooted environment will not either (this is something that has not been tested). Instructions on installing Splunk in a chrooted environment can be found here: http://www.splunk.com/support/1228

View solution in original post

0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!