Installation

After upgrading to Splunk 6.3, why do users have to constantly clear the cache several times a day for Splunk Web to function properly?

ryandg
Communicator

Hi,

So we have 2 instances of Splunk installed, both of which have been upgraded to 6.3 over the past month or so. Both of the setups are very different so the only similarity is the version upgrade. Since the upgrade, people (around 12+ different individuals) have to constantly state that they cannot perform searches, access apps. Whenever I view their page, the Splunk Web UI doesn't have their user ID loaded and they need to clear the cache so that Splunk properly works via Web UI. However, it isn't just one time that each individual needs to do this, it's probably 3-5 times per day! I have to clear my cache every few hours so that I can continue working on splunk apps. It's highly frustrating and I can't seem to find this documented anywhere as a known bug.

For an example of what it looks like, it is literally blank where the username should be:

Splunk

Also if you try to search while this happens it displays the message:

In handler 'savedsearch': Cannot get username when all users are selected.

And if you go to the launcher it looks like this:

alt text

Labels (1)
0 Karma
1 Solution

jhupka
Path Finder

I've had similar issues when going from 6.2.5 to 6.3.1 - missing user, broken images, menus don't work. It sucked and I would get so upset not even kitten pictures on the internet would cheer me up.

This is due to a bug in Python 2.7.9, a new version of Python Splunk uses under the hood in 6.3. See this Splunk Answer for a solution. It worked like a charm for me:

https://answers.splunk.com/answers/312247/after-upgrading-a-search-head-cluster-to-splunk-63-1.html

http://docs.splunk.com/Documentation/Splunk/6.3.1/ReleaseNotes/Knownissues#Splunk_Web_and_Home_inter...

View solution in original post

jhupka
Path Finder

I've had similar issues when going from 6.2.5 to 6.3.1 - missing user, broken images, menus don't work. It sucked and I would get so upset not even kitten pictures on the internet would cheer me up.

This is due to a bug in Python 2.7.9, a new version of Python Splunk uses under the hood in 6.3. See this Splunk Answer for a solution. It worked like a charm for me:

https://answers.splunk.com/answers/312247/after-upgrading-a-search-head-cluster-to-splunk-63-1.html

http://docs.splunk.com/Documentation/Splunk/6.3.1/ReleaseNotes/Knownissues#Splunk_Web_and_Home_inter...

Get Updates on the Splunk Community!

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...

Splunkbase | Splunk Dashboard Examples App for SimpleXML End of Life

The Splunk Dashboard Examples App for SimpleXML will reach end of support on Dec 19, 2024, after which no new ...

Understanding Generative AI Techniques and Their Application in Cybersecurity

Watch On-Demand Artificial intelligence is the talk of the town nowadays, with industries of all kinds ...