Getting Data In

windows memory leaks

omprakash9998
Path Finder

Hi,

we Have been trying to detect any memory leaks on our windows servers. As of now we are just trying to compare the virtual bytes counter for two different time ranges and tracking the increase in the memory usage by a process.Later we are trying to detect patterns by saving the results in a lookupfile. Is there a better approach to achieve this.

Thanks

0 Karma

at1ll3y
New Member

Hi,
Could you provide your search queries?

0 Karma

omprakash9998
Path Finder
index=perfmon eventtype="perfmon_windows" (Host="*") Host="*" object=Process counter="Private_Bytes" earliest=-30m@m latest=-20m@m 
  | stats avg(Value) AS older  by host process_name 
  | join [search index=perfmon eventtype="perfmon_windows" (Host="*") Host="*" object=Process counter="Private_Bytes" earliest=-20m@m latest=-10m@m   | stats avg(Value) AS newer  by host process_name _time | convert ctime(_time) as time  ]  |eval diff= newer - older | eval percent = (diff/older)*100 
  |table host, process_name, older, newer, percent , time| where newer >  4 * older | sort - percent | outputlookup append=true autotestlookup.csv

this is our current search query to compare the memory and save it in a lookup file. I am not sure if the approach we are trying is the best option.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Unlocking Unified Insights: New Gigamon Federated Search App for Splunk

In today’s data-heavy environment, organizations are caught in a data distribution dilemma. As data volumes ...

GA: New Data Management App in Splunk Platform

Streamlining Data Management: Introducing a unified experience in Splunk Managing data at scale shouldn’t feel ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...