Getting Data In

truncate logs with syslog

torbael
Explorer

Hi,

I'm using an UDP connection with syslog and Splunk.

My problem is that Splunk only show me the firsts 2072 characters of a log. I try to increase the values of "TRUNCATE" and "MAX_EVENTS" inside the props.conf, but it didn't work.

Also I checked with Wireshark that the logs are sended correctly with syslog.

Any suggestions?

Thanks.

Tags (1)
1 Solution

jaoui
Path Finder

I was told that Splunk's syslog implementation is 'RFC compliant' so that it only accepts the first 1KB of a syslog message. Maybe you are running into something related to that limitation?

View solution in original post

jaoui
Path Finder

I was told that Splunk's syslog implementation is 'RFC compliant' so that it only accepts the first 1KB of a syslog message. Maybe you are running into something related to that limitation?

jbsplunk
Splunk Employee
Splunk Employee

Not sure if this will help, but did you try setting TRUNCATE = 0? Also, you should keep in mind that MAX_EVENTS only take affect if SHOULD_LINEMERGE = true.

0 Karma
Get Updates on the Splunk Community!

Adoption of RUM and APM at Splunk

    Unleash the power of Splunk Observability   Watch Now In this can't miss Tech Talk! The Splunk Growth ...

March Community Office Hours Security Series Uncovered!

Hello Splunk Community! In March, Splunk Community Office Hours spotlighted our fabulous Splunk Threat ...

Stay Connected: Your Guide to April Tech Talks, Office Hours, and Webinars!

Take a look below to explore our upcoming Community Office Hours, Tech Talks, and Webinars in April. This post ...